Ubuntu VMware Workstation/Player modules in kernel Update/Compile Error

반응형

Ubuntu Linux에서 VMware Player/Workstation을 사용하실 때, Linux Kernel Update 한 이후, 다음과 같은 메시지를 보실 수 있습니다.



이 메시지는 VMware 실행을 위해 커널에서 읽는 모듈을 새로 업데이트 해야한다는 메시지입니다.



바로 위 메시지처럼 appLoader에서 오류가 발생합니다. 아직 정확한 원인은 알 수 없지만, 아마 VMware 쪽에서 3.8용 모듈 패키지를 제작하지 않은 듯합니다.


어쨌든 다음과 같은 방법으로 오류를 해결하실 수 있습니다.


$ sudo vmware-modconfig --console --install-all

or

# vmware-modconfig --console 



위 방법으로 console에서 직접 make 명령어를 이용해 업데이트한 커널에서 직접 컴파일합니다. 중간에 2.6.x 관련하여 이미 수행한 작업들이 있다고 하지만, 리눅스 커널이 올라가면서 VMware 관련 모듈들이 일부 존재했을 수도 있으므로 그냥 무시하셔도 됩니다.


반응형

Tistory Comments 0